All Discussions - enGrid Forum Mon, 28 Jul 14 08:18:50 -0400 All Discussions - enGrid Forum en-CA New Forum on CFD-Online Fri, 28 Dec 2012 06:35:02 -0500 admin 310@/vanilla/index.php?p=/discussions
I am please to announce that there is a dedicated enGrid forum on CFD-Online.

The new forum can be found here:

This old forum will be available as read-only until we have figured out how to conserve the old discussions for reference purposes.

Best regards,
wrongOrientedFaces Wed, 31 Mar 2010 15:21:44 -0400 yeahright 93@/vanilla/index.php?p=/discussions I'm trying to mesh a fan/propeller. If I create the prismatic layer, the checkMesh utility complains about :

***Error in face pyramids: 14 faces are incorrectly oriented.
<<Writing 12 faces with incorrect orientation to set wrongOrientedFaces

This sounds alarming, OF does however compute something resembling a flow before divergence ... What does that mean ?

Can I avoid this by adjusting the boundary layer parameters, any suggestions ?

Kind regards
No CGNS Support Sat, 10 Apr 2010 20:59:36 -0400 Pat84 95@/vanilla/index.php?p=/discussions
i have installed engrid on ubuntu as descriped. At the end of the tutorial i tried to export the mesh in cgns, but i got an Error.

The error message is follow:

CGNS support has not been compiled

file: cgnswriter.ccp

I don't know what to do, because i have installed cgns with engrid. I tried to install cgns again, but nothing changed.

I hope someone can help me with my issue.

Kind regards,
limits of 1000000 Mon, 17 Dec 2012 19:27:29 -0500 elephantwalker50 309@/vanilla/index.php?p=/discussions
I'm trying to model a fairly complex geometry, and have plenty of cpu's and gb. Is there any way to extend this limit?

enGrid 1.4 Wed, 05 Dec 2012 08:28:27 -0500 engrid_user 307@/vanilla/index.php?p=/discussions
I am trying to use enGrid 1.4 with a simple example (small sphere inside a bigger one). I have some questions:

- I am not able to modify only the color of the small sphere. Colors of both spheres change together.
- What A<< and B>> mean (in the edit boundary condition window) ?

Best regards,
installation enGrid 1.4 Tue, 04 Dec 2012 10:24:42 -0500 engrid_user 306@/vanilla/index.php?p=/discussions
I try to install enGrid 1.4 on an openSUSE 12.1 system.
After the 'make' command I get the following error message !

/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: warning:, needed by /usr/lib64/, not found (try using -rpath or -rpath-link)
/usr/lib64/ undefined reference to `mysql_list_fields@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_fetch_row@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_query@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_list_tables@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_result_metadata@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_real_escape_string@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_fetch_field_direct@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_init@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_execute@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_num_fields@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_fetch_lengths@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_close@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_field_count@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_init@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_store_result@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_error@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_get_server_version@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_real_connect@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_data_seek@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_error@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_param_count@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_close@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_free_result@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_get_client_version@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_fetch_field@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_errno@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_bind_param@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_options@libmysqlclient_16'
/usr/lib64/ undefined reference to `mysql_stmt_prepare@libmysqlclient_16'
collect2: ld returned 1 exit status
make[2]: *** [engrid] Error 1
make[1]: *** [release] Error 2
make: *** [sub-engrid-pro-app-make_default-ordered] Error 2

I need some help. Thanks.

ehGrid 1.4 support chtMultiRegionFoam case? Tue, 27 Nov 2012 21:40:45 -0500 phsieh2005 305@/vanilla/index.php?p=/discussions
I saw on OpenFoam forum that enGrid 1.4 support openFoam chtMultiRegionFoam case. Is it true? Is there any tutorial on how to do this?


Improving the quality of the polyhedral cells Tue, 11 Sep 2012 08:27:47 -0400 lhcamilo 296@/vanilla/index.php?p=/discussions

I am sorry to bother you with this, but recently I have been using engrid to generate a hex-polyhedra mesh hybrid grid for a pipe geometry to be run in OpenFOAM. The hexahedra mesh compose the boundary layer near the wall and the polyhedra compose the bulk region of the pipe. The tutorials have been quite helpful and thus far I have been quite successful. I was really pleased with the way the transition between hex/polyhedra was handled by Engrid.

However as the following picture suggests,( ), there is still room for improvement. I have market out the type of cells that I want to avoid.

Basically, I would like to humbly request some tips on how to create a more smooth polyhedral mesh in the bulk region and avoid such irregular cells. I am not sure exactly how to tackle this problem, I am clearly out of my depth here but I am eager to learn. Are there any particular settings that could help me? Should I try to improve the improve the surface mesh to produce more isometric triangles (and if so how would I go about doing that?)?

Thanks in advance for the help.

encountered problem when working on the damper example using enGrid 1.4 Sat, 24 Nov 2012 09:06:14 -0500 phsieh2005 304@/vanilla/index.php?p=/discussions
I just installed enGrid 1.4 on both Win 7_64 and OpenSUSE 12.2 64. When I was trying out the damper example, I encountered an error during the step of "Create the Volume Mesh" after I clicked "Mesh>> create/improve volume mesh (NETGEN)". I got a window popped up, saying: Netgen stopped with the following error: Illegal state observed in SwapImprove". I am wondering what I did wrong.


Please Help with Engrid 1.3 Install on Ubuntu 12.04 Sun, 11 Nov 2012 09:59:53 -0500 jmct 301@/vanilla/index.php?p=/discussions engrid 1.3 /1.4 run error Thu, 08 Nov 2012 09:58:34 -0500 keepfit 299@/vanilla/index.php?p=/discussions
symbol lookup error: ./libengrid/ undefined symbol: _ZTVN6netgen11NgExceptionE

So I switched to enGrid 1.3, but the same error remains.

Furthermore, there was compile error:

main.cpp: In function ‘void makeDistribution()’:
main.cpp:123:36: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
main.cpp:124:26: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
main.cpp:125:30: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
main.cpp:140:30: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
main.cpp:144:48: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
main.cpp:145:27: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
main.cpp:146:24: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]

by checking the link libraries of engrid

$ ldd engrid

i found is missing, but it did exit in ..src/libengrid => (0xb77c0000) => not found => /lib/i386-linux-gnu/ (0xb7785000) => /usr/lib/i386-linux-gnu/ (0xb6cb2000) => /usr/lib/i386-linux-gnu/ (0xb69d5000) => /usr/lib/i386-linux-gnu/ (0xb68f0000) => /lib/i386-linux-gnu/ (0xb68d1000) => /lib/i386-linux-gnu/ (0xb6727000)
/lib/ (0xb77c1000) => /usr/lib/i386-linux-gnu/ (0xb66f3000) => /usr/lib/i386-linux-gnu/ (0xb66da000) => /lib/i386-linux-gnu/ (0xb65e1000) => /lib/i386-linux-gnu/ (0xb65b6000) => /lib/i386-linux-gnu/ (0xb65a0000) => /usr/lib/i386-linux-gnu/ (0xb6506000) => /usr/lib/i386-linux-gnu/ (0xb64b7000) => /usr/lib/i386-linux-gnu/ (0xb64ae000) => /usr/lib/i386-linux-gnu/ (0xb6493000) => /usr/lib/i386-linux-gnu/ (0xb6483000) => /usr/lib/i386-linux-gnu/ (0xb6479000) => /usr/lib/i386-linux-gnu/ (0xb6467000) => /usr/lib/i386-linux-gnu/ (0xb6333000) => /lib/i386-linux-gnu/ (0xb6306000) => /lib/i386-linux-gnu/ (0xb6301000) => /lib/i386-linux-gnu/ (0xb62f8000) => /lib/i386-linux-gnu/ (0xb62ce000) => /usr/lib/i386-linux-gnu/ (0xb6272000) => /usr/lib/i386-linux-gnu/ (0xb626d000) => /lib/i386-linux-gnu/ (0xb6231000) => /usr/lib/i386-linux-gnu/ (0xb622a000) => /lib/i386-linux-gnu/ (0xb6224000) => /usr/lib/i386-linux-gnu/ (0xb6203000) => /usr/lib/i386-linux-gnu/ (0xb61fb000)


So I wonder, how to fix this problem, thanks very much.


Multiple Volumes deleted during Prism Layer dividing Wed, 17 Oct 2012 10:59:08 -0400 gorkgt 298@/vanilla/index.php?p=/discussions
I wanted to use Engrid for the generation of a multiple volume mesh. It works pretty fine until the Prism Layer is to be divided. This means I have 3 regions (1 fluid, 2 solid) and in the fluid region there is a prismatic boundary layer. After the prismatic boundary layer is created all three regions are meshed with tets. Now the problem occurs when trying to divide the prism layer into several layers. The volume elements as well as the boundary codes of the solid regions are deleted (If I want to remesh them the error message "The grid appears to be empty. file: createvolumemesh.cpp line:348" appears.)

I would we very thankful for some explanation or even more for a solution of my problem :)


Sharp-angled cone Fri, 07 Sep 2012 06:55:42 -0400 Astarta 293@/vanilla/index.php?p=/discussions I`ve got problems with meshing cone.
When I make surface mesh - enGrid changes shape and cause of it I can`t make volume mesh. Reducing of edge length doesn`t help.
Any help will be appreciated.

Best regards,
how to save mesh data with engrid Sat, 15 Sep 2012 06:39:02 -0400 rvs 297@/vanilla/index.php?p=/discussions I have two questions.
1) As I know from tutorials engrid can construct the layer of prisms from triangulated boundary. For my problem of research I need the mesh in which I have the layer of triangle prisms at one boundary and the tetrahedral grid in the other part of complex domain. To merge these grids the mesher must construct the layer of pyramids.
Can I do hybrid grid (tetrahedra, prism, pyramids) with engrid?

2) I ask you to tell me please, is it possible to save the grid data (points, edges, faces, elements (tetrahedron, hexahedron, pyramids, prisms)) after I have contructed the mesh with the edgrid. I mean *ele, *.faces, *.edges, *.node files, as it can be done for example with Tetgen by Hang Si. I need this information because I am writing my own program for flow calculations and I am not really use any solver.
May be you can advise me some program or converter where I can get information that I need.
Very hope on your answer,
Thank you.]]>
New Blender Exporter Fri, 07 Sep 2012 13:06:15 -0400 Andid 294@/vanilla/index.php?p=/discussions
Here it is(unfortunately I dont know how to attach files):
# ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
# + +
# + This file is part of enGrid. +
# + +
# + Copyright 2008-2010 enGits GmbH +
# + +
# + enGrid is free software: you can redistribute it and/or modify +
# + it under the terms of the GNU General Public License as published by +
# + the Free Software Foundation, either version 3 of the License, or +
# + (at your option) any later version. +
# + +
# + enGrid is distributed in the hope that it will be useful, +
# + but WITHOUT ANY WARRANTY; without even the implied warranty of +
# + GNU General Public License for more details. +
# + +
# + You should have received a copy of the GNU General Public License +
# + along with enGrid. If not, see <<a href="" target="_blank" rel="nofollow">>. +
# + +
# ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

bl_info = {
"name": "Engrid (*.begc)",
"description": "Export to Engrid",
"author": "Engit",
"version": (1, 2),
"blender": (2, 60, 0),
"location": "File > Export > Engrid (*.begc) ",
"warning": "", # used for warning icon and text in addons panel
"wiki_url": "",
"tracker_url": "",
"category": "Import-Export"}

import bpy
from bpy.props import StringProperty

def do_export(filename):
if not filename.lower().endswith('.begc'):
filename += '.begc'
out = open(filename, "w")
objects = bpy.context.selected_objects

num_objects = 0
for object in objects:
if object.type == 'MESH':
num_objects = num_objects + 1

out.write('%d\n' % num_objects)
node_offset = 0
for object in objects:
if object.type == 'MESH':
for object in objects:
if object.type == 'MESH':
mesh =
faces = mesh.polygons
nodes = mesh.vertices
out.write('%d' % len(nodes))
out.write(' %d\n' % len(faces))
for n in nodes:
out.write("%e " %[0])
out.write("%e " %[1])
out.write("%e\n" %[2])
for f in faces:
N = len(f.vertices)
if N < 3 and N > 4:
print('Error%t|Only triangles and quads allowed')
out.write("%d" % N)
for v in f.vertices:
out.write(' %d' % (v + node_offset))
node_offset = node_offset + len(nodes)

class EngridExporter(bpy.types.Operator):
"""Export the selected Objects to Engrid"""
bl_idname = "export.engrid"
bl_label = "Export Engrid"

filepath = StringProperty(subtype='FILE_PATH')

def execute(self, context):
#Append .x
FilePath = bpy.path.ensure_ext(self.filepath, ".begc")


return {"FINISHED"}

def invoke(self, context, event):
if not self.filepath:
self.filepath = bpy.path.ensure_ext(, ".begc")
WindowManager = context.window_manager
return {"RUNNING_MODAL"}

### REGISTER ###

def menu_func(self, context):
self.layout.operator(EngridExporter.bl_idname, text="Engrid (.begc)")

def register():


def unregister():


if __name__ == "__main__":

Bug as described in Issue 19 encountered Fri, 07 Sep 2012 13:15:38 -0400 Andid 295@/vanilla/index.php?p=/discussions i'm using the windows version of engrid and I have the Problem with line 82 in simplefoamwriter.cpp as described here

The file I used can be downloaded here (because I don't know how to deal with attachments in this board).

Hope anyone could help me.

The file is created via Blender and Netgen (and Netfabb because Netgen wasn't able to read Blenders stl).

zeroVolumeCells Sun, 02 Sep 2012 19:02:53 -0400 atypicalguy 292@/vanilla/index.php?p=/discussions
I exported my case to OpenFoam from Engrid, but when I run checkMesh it fails with a floating point exception after writing zeroVolumeCells. I have checked the surface mesh in enGrid and it is OK. Does anyone know how to get rid of the zero volume cells? I have run create/improve volume mesh in enGrid many times without benefit.

Also, running "delete bad aspect ratio cells" does not appear to work on my mesh, though checkMesh seems to not mind as much.


(OF:1.6-ext Opt) caelinux@karl-OF:OFtest2$ checkMesh
| ========= | |
| \\ / F ield | OpenFOAM Extend Project: Open source CFD |
| \\ / O peration | Version: 1.6-ext |
| \\ / A nd | Web: |
| \\/ M anipulation | |
Build : 1.6-ext-30132395b0df
Exec : checkMesh
Date : Sep 02 2012
Time : 15:25:53
Host : karl-OF
PID : 25684
Case : /home/caelinux/OpenFOAM/caelinux-1.6-ext/run/OFtest2
nProcs : 1
SigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create polyMesh for time = 0

From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshInitMesh.C at line 82
Truncating neighbour list at 7014686 for backward compatibility
Time = 0

Mesh stats
all points: 1351889
live points: 1351889
all faces: 7261298
live faces: 7261298
internal faces: 7014686
cells: 2978166
boundary patches: 9
point zones: 0
face zones: 0
cell zones: 0

Overall number of cells of each type:
hexahedra: 0
prisms: 2363320
wedges: 0
pyramids: 0
tet wedges: 0
tetrahedra: 614846
polyhedra: 0

Checking topology...
Boundary definition OK.
Point usage OK.
Upper triangular ordering OK.
Face vertices OK.
Number of regions: 1 (OK).

Checking patch topology for multiply connected surfaces ...
Patch Faces Points Surface topology
Bottom 31348 17150 ok (non-closed singly connected)
BottomTip 5922 3286 ok (non-closed singly connected)
Far 372 209 ok (non-closed singly connected)
Leading 98911 52157 ok (non-closed singly connected)
LeadingTip 61827 31506 ok (non-closed singly connected)
Sym 9908 6439 ok (non-closed singly connected)
Tip 1268 707 ok (non-closed singly connected)
Top 31172 17113 ok (non-closed singly connected)
TopTip 5884 3282 ok (non-closed singly connected)

Checking geometry...
This is a 3-D mesh
Overall domain bounding box (-8.42746e-07 -3.21339 -3.21528) (3.18778 3.2111 3.20832)
Mesh (non-empty, non-wedge) directions (1 1 1)
Mesh (non-empty) directions (1 1 1)
Mesh (non-empty, non-wedge) dimensions 3
Boundary openness (-6.63691e-15 5.14825e-18 -5.31685e-19) Threshold = 1e-06 OK.
***High aspect ratio cells found, Max aspect ratio: 3.4023e+06, number of cells 45848 Threshold = 1000
Writing 45848 cells with high aspect ratio to set highAspectRatioCells
***Zero or negative face area detected. Minimum area: 0
Writing 186 zero area faces to set zeroAreaFaces
***Zero or negative cell volume detected. Minimum negative volume: -2.75184e-06, Number of negative volume cells: 235998
Writing 235998 zero volume cells to set zeroVolumeCells
Floating point exception
Error: Boundary code 1 has not been properly defined Wed, 25 Nov 2009 07:21:29 -0500 wfc03002 67@/vanilla/index.php?p=/discussions
boundary code 1 has not been properly defined

file: openfoamcase.cpp

I suspect this has to do with an issue I encountered earlier... I was unable to combine boundaries 2,5,6, and 7 (as I do not know how).

In addition I do not know what parameters to enter in the Tools>configure engrid section...

Any advice would be most helpful.


Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/system/controlDict"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/0/U"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/0/p"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/0/k"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/0/epsilon"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/0/omega"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/constant/transportProperties"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/constant/RASProperties"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/system/fvSchemes"
Writing to "/home/bill/OpenFOAM/bill-1.6.x/run/tutorials/throttle/system/fvSolution"
:cry: Error Code prompt
deleting Operation 0x9be4bf0]]>
Export from Blender Thu, 06 May 2010 10:39:56 -0400 paul 99@/vanilla/index.php?p=/discussions
I just tried out the export script and encountered a problem. This is what I did: I imported a simple geometry (stl) into blender, scaled it down with factor 0.001, manually remeshed it and put a cube around it to generate the outer boundary of the fluid domain. When I import this into blender using the script the cube shows up in its desired size but the former stl geometry turns out to be in its original size, i.e. without the scaling i did in blender.
Maybe its just me not knowing to scale this properly in blender, so I would appreciate if you could have a short look at the blender and begc files please!

Thanks a lot and best regards,
Trouble installing EnGrid on Ubuntu 12.04 Thu, 19 Jul 2012 15:10:50 -0400 RocheDEM 289@/vanilla/index.php?p=/discussions Hi,

I tried to install engrid using the build.bash from git. The script appears to run properly and install the program. Then I use engrid/setup_generic.bash, which appears to function correctly (I have the EnGrid icon in my start menu).

When I try to run Engrid from the start menu or by typing engrid in a terminal nothing happens, here is the error message that I get;

laurie@Anzac:~$ engrid
/home/laurie/Documents/engrid/run.bash: line 26: /home/laurie/Documents/engrid/src/engrid: No such file or directory

Please help me to understand what has gone wrong and what I need to do to fix the install.

Thank you,