Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

Multiple Volumes deleted during Prism Layer dividing
  • gorkgt October 2012
    Hello,

    I wanted to use Engrid for the generation of a multiple volume mesh. It works pretty fine until the Prism Layer is to be divided. This means I have 3 regions (1 fluid, 2 solid) and in the fluid region there is a prismatic boundary layer. After the prismatic boundary layer is created all three regions are meshed with tets. Now the problem occurs when trying to divide the prism layer into several layers. The volume elements as well as the boundary codes of the solid regions are deleted (If I want to remesh them the error message "The grid appears to be empty. file: createvolumemesh.cpp line:348" appears.)

    I would we very thankful for some explanation or even more for a solution of my problem :)

    regards

    Georg
  • wyldckat October 2012
    Greetings Georg,

    A few of questions:
    1. Which version of enGrid are you using?
    2. What Operating System are you using?
    3. Is it possible for you to share a small example case that demonstrates this?

    Best regards,
    Bruno
  • Oliver October 2012
    Hello George,

    Which version of enGrid are you using? If you haven't done so yet, please try the release-1.4 branch from the GIT repository. If the problem persists, could you make your case available for download somewhere.

    Regards,
    Oliver
  • Oliver October 2012
    Hi Bruno,

    Our replies must have overlapped, because I didn't see your post when I replied.

    Cheers,
    Oliver
  • gorkgt October 2012
    Hi, thanks for the replies!
    I am using enGrid 1.3 so far on an Ubuntu 12.04 OS. I will try it with the 1.4 version and report about the results...what I haven't tried is meshing the same case on a windows machine...will do as well

    For a better understanding of my case: I want to create a mesh with multiple regions in oder to simulate with sliding grid method. the Mesh initially was created with Salome, exported to foam and then imported to enGrid. During the import in enGrid the volume Mesh gets lost, so I remeshed everything in enGrid: surface, Prism Layer and Volumes.

    Case available under:

    https://www.dropbox.com/sh/cvca65c7n9eq0m2/FDS0kWOUnE

    cheers Georg

  • gorkgt October 2012
    Tried to build release 1.4 but couldn't make it.

    if I change to release branch 1.4 with:

    git checkout -b release-1.4 remotes/origin/release-1.4

    I cannot execute

    source scripts/setup_pathes.bash ubuntu-12.04

    only older version are suggested

    xxx@ubuntu:~/engrid/src$ source scripts/setup_pathes.bash ubuntu-12.04
    usage :
    source setup_pathes.bash CONFIGURATION
    CONFIGURATION = ubuntu-11.10
    ubuntu-11.04
    ubuntu-10.10
    opensuse32
    opensuse64
    opensuse32-12
    opensuse64-12
    fedora32
    fedora64

    If I stick to the 1.3 branch everything works fine...where is my mistake? :)
  • gorkgt October 2012
    meshed the case in 1.4 windows beta and it works fine, thanks you very much - leaves only my problem installing the 1.4 version to my ubuntu 12.04 64 bit machine...if you could please help me with that issue...?

    thanks

    Georg
  • wyldckat October 2012
    Hi Oliver and Georg,

    @Oliver: It's all about timing. ;) And I was 15% asleep already as well... eheh

    @Georg: enGrid 1.4.0 is still in a pseudo-beta state, which is why the branch release-1.4 isn't fully working yet, when it comes to the installation scripts. You can either use the instructions from here: https://github.com/enGits/engrid/issues/29#issuecomment-8782113 - more specifically, run these commands:
    wget https://raw.github.com/wyldckat/engrid/sandbox-1.4/build.bash
    chmod +x build.bash
    ./build.bash

    Or you can try out the PPA I created some weeks ago: https://launchpad.net/~wyldckat/+archive/engrid-ppa

    Best regards,
    Bruno
  • gorkgt October 2012
    Hi Bruno, hi Oliver,

    thank you very much for the support! Works flawlessly now...

    best regards Georg