Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

compile errors - enGrid_1.0 on SUSE 11.0 at 64 bit.
  • admin March 2009
    Hi,
    As far as I know, enGrid looks very promissing for mesh generation for
    CFD and I am willing to test it. Meanwhile, however, I tried to compile
    enGrid_1.0 on SUSE 11.0 at 64 bit, but the make command was followed by
    a lot of errors. The first lines of errors were:

    /In file included from main.cpp:30:
    guimainwindow.h:37:33: error: vtkUnstructuredGrid.h: No such file or
    directory
    guimainwindow.h:38:22: error: vtkActor.h: No such file or directory
    guimainwindow.h:39:31: error: vtkPolyDataMapper.h: No such file or directory
    guimainwindow.h:40:31: error: vtkGeometryFilter.h: No such file or directory
    guimainwindow.h:41:32: error: vtkCubeAxesActor2D.h: No such file or
    directory
    guimainwindow.h:42:27: error: vtkCellPicker.h: No such file or directory
    guimainwindow.h:43:29: error: vtkSphereSource.h: No such file or directory
    /
    Apparently, the compiler does not find the VTK dir. I have installed VTK
    5.1.1-6.2, using YAST with a suse repository.

    Regards,
    VĂ­tor
  • admin March 2009
    I tried compiling enGrid against VTK libraries installed from rpms for
    openSUSE 10.3 and failed too so far. :(

    Anyway, here's a simple archive with all the required libraries:
    http://engits.com/ogloth/enGrid_linux64bit_1.0.tar.gz
    It also contains the source code in case you want to recompile it.

    If you still want to compile using the libraries installed from RPM,
    first make sure you have the following packages installed:
    -vtk
    -vtk-qt
    -vtk-devel

    Then try modifying "engrid.pro" as follows:
    1)Replace
    LIBS += -L$(VTKDIR)/lib/$(VTKVERSION)
    LIBS += -L$(VTKDIR)/lib/vtk-5.2
    with
    LIBS += -Lpath_to_vtk_libs

    2)Replace
    INCLUDEPATH += $(VTKDIR)/include/$(VTKVERSION)
    with
    INCLUDEPATH += path_to_vtk_headers

    On OpenSUSE 10.3, the libraries were in "/usr/lib64" and the headers in
    "/usr/include/vtk".
    However, the vtk-qt rpm seems to use Qt3 instead of Qt4.